
>Topic<Welcome to Pegged!

Object:    The object of Pegged is to remove all but one peg from the playing 
board.    Pegs are removed from the board by jumping one peg over another.
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Ok, you may be wondering why the "pegs" look so much like beads (or marbles or 
whatever).    I'm not really crazy, just a poor artist.    Anyway, it's pretty easy to draw 
circles, so that's what I went with.

Winning/Losing:    When only one peg remains, you win.    If there is more than 
one peg left on the board and there are no legal moves remaining, you curse (um,
I mean lose).

Playing:    Start a game by moving a peg.    If you are hopelessly lost or want to 
start over, simply select New Game from the File menu (or use the Play smart-
icon).

Taking Back Moves:    We all aren't perfect, so occationally you might make a 
really stupid mistake after hours and hours of study.    Instead of being severly 
punished, you can take back that move using the Take Back command from the 
File menu (or use the smart-icon).    You can take back as many moves as you 
want (e.g., the last two, three, etc.), all the way back to the beginning of a game (if 
you really want).

Large Board:    By clicking on the zoom box in the main Pegged window, or 
selecting Large Board under the File menu, you can change the size of the 
Pegged window between the regular size and a "large" size (which is exactly 
twice the size of the regular board).    Of course, your monitor better be big 
enough for the large window size (give it a try and see).    Pegged will remember 
the window size you have selected next time you play.

Auto Advance:    With the auto advance feature turned on, the next puzzle will 
automatically be selected for you once you solve the current one.    If you have 
just solved the last puzzle for a board, the first puzzle on the next board will be 
selected.



Saving The Puzzle and Board You're On:    The current board and puzzle number 
you're on will be saved when you quit Pegged so that the next time you play, you 
can start off where you were last time.

Boards:    There are numerous peg board syles, and each board presents its own 
challenges.    Select a board style from the Board menu (or use the appropraite 
smart-icon).

Puzzles:    Each board has a number of puzzles to solve.    Use the Puzzles menu 
to select the puzzle you want to solve (or, again, use the appropriate smart-icon).  

Sound:    If you have system 6.0.2 or later, you have the option of digitized sound.  
Selecting Sound from the File menu will toggle sound on/off.

Color Graphics:    To have the color graphics work, you must be using system 
6.0.4 or later, and have 32-bit color quickdraw.    Note:    There is a small bug in the
program that doesn't release memory if you frequently change your monitor from 
black-and-white mode to color and back while the program is running.    I can't 
find it anywhere at this time, so I recommend that you don't change from color to 
black-and-white too much when running this program (don't worry - you can still 
do it once or twice without problems, or increase the memory setting for the 
program).

Pegged's graphics use only 16 colors, but for speed, I try to draw offscreen 
graphics at the same number of colors as your monitor.    However, if you do not 
have enough memory allocated for Pegged, offscreen graphics will have to be 
drawn in 16 colors instead of the number of colors set for your monitor.    This 
may cause the graphics to be drawn more slowly since your Macintosh will have 
to convert between the 16 colors offscreen and the number of colors your 
monitor it set to.    To fix this problem, set the memory setting in the "Get Info" 
box to the following settings, depending on your monitor's number of colors:    
320K for 16 colors, 448K for 256 colors, 768K for thousands of colors, and 1024K 
for millions of colors.    Note that the "Minimum Size" is the memory setting I use 
to determine how much memory you have allocated for Pegged.    Alternatively, 
you could also use the Monitors control panel to set your monitor to 16 colors.    
The first option, though, is probably most convenient for you.

Color Depth Warnings:    When this option is turned on, you will be warned when Color Depth Warnings:    When this option is turned on, you will be warned when 
Pegged can not draw offscreen graphics at the same color depth your monitor is Pegged can not draw offscreen graphics at the same color depth your monitor is 
set to due to memory limitations (in other words, you haven't set the memory sizeset to due to memory limitations (in other words, you haven't set the memory size
in the Get Info... Box high enough).    You'll still get color graphics, but screen in the Get Info... Box high enough).    You'll still get color graphics, but screen 
drawing speed may be reduced.    It's probably best to keep this on unless you'll drawing speed may be reduced.    It's probably best to keep this on unless you'll 
always be playing Pegged at a memory setting too low to support the number of always be playing Pegged at a memory setting too low to support the number of 
colors you have your monitor set to.colors you have your monitor set to.



>Topic<Creating Your Own Puzzles

After solving all the boards and puzzles I've supplied, you may want to create your own. 
Using the commands under the Custom menu, you can create puzzles for existing 
boards, or even create your own boards.    The following commands are available under 
the Custom menu.

New Puzzle:    Use this command to create a new puzzle for the currently selected 
board.    After selecting this command, you will be presented with a blank board (don't 
panic, you didn't just blow anything away).    You will create the puzzle in the opposite 
order that a player would solve that puzzle.    This means that you will start with one peg
on the board, and by "jumping" pegs over blank holes, add pegs to the board.    This 
ensures that every puzzle you create will have a solution (and actually, will save you 
hours and hours of frustration trying to solve an unsolvable puzzle you just created).

To place the first peg on the board (or the last from the player's perspective), simply 
click on a peg hole.    The first peg will appear.    To begin creating the puzzle, jump that 
peg over a blank spot on the board.    A peg will be added to the hole you just jumped.    
Continue this process until you have created the puzzle.    Note that you can use the 
Take Back command from the File menu (or smart-icon) to take back moves while 
creating a puzzle (and you can take back moves to the very beginning).    After you have
finished creating your puzzle, select Save from the Custom menu.    If you decide you 
don't want to keep the puzzle, select Abort from the Custom menu.

Copy Puzzle:    If you want to create a new puzzle and use an existing puzzle as a sort 
of "template" for that new puzzle, select Copy Puzzle from the Custom menu.    This will 
place you into edit mode and start you off with the currently selected puzzle.    You can 
then make your changes to that puzzle and save them into a new puzzle.

Edit Puzzle:    If you want to edit one of the puzzles you've created, select Edit Puzzle 
from the Custom menu.    This will allow you to edit the currently selected puzzle and 
save it over the old one (you also have the option of changing its name).    You can not 
edit the puzzles I've supplied with the game (one of the perks of being the 
programmer!).

Delete Puzzle:    If you are unhappy with a puzzle you've created and saved, use Delete 
Puzzle from the Custom menu to delete the currently selected puzzle.    You can't delete 
the original puzzles, of course, since that would be quite silly.

Save and Abort:    See the topics of the same name in the following section (Creating 
you own Boards).

Interesting Twist:    Even if you have no desire to create new puzzles, it is very 
challenging to "create" some of the existing patterns.    Use the new puzzle command to 
try to create the patterns of existing puzzles.    It isn't as easy as it looks!



>Topic<Creating Your Own Boards

Ok, now you've totally mastered the boards built into Pegged.    Now what?    No, 
don't go play Glider or Bachman.    Make up your own boards.    The following 
commands are available under the Custom menu:

New Board:    Use this command to create a new peg board.    Boards can be up toNew Board:    Use this command to create a new peg board.    Boards can be up to
9 squares by 9 squares.    After selecting this command, you will be presented 9 squares by 9 squares.    After selecting this command, you will be presented 
with a 9 by 9 grid.    Initially, all grid squares are empty.    By clicking on a grid with a 9 by 9 grid.    Initially, all grid squares are empty.    By clicking on a grid 
square, you can toggle the contents of that sqaure.    If the square is empty, a square, you can toggle the contents of that sqaure.    If the square is empty, a 
piece of    a peg board will be placed on that square.    If there is a piece of peg piece of    a peg board will be placed on that square.    If there is a piece of peg 
board on the clicked square, it will be cleared.    Create the board and select Save board on the clicked square, it will be cleared.    Create the board and select Save 
from the Custom menu.    Use Abort if you decide not to save your creation.from the Custom menu.    Use Abort if you decide not to save your creation.

After creating a new board, a single blank puzzle will automatically be created After creating a new board, a single blank puzzle will automatically be created 
(you will see it under the Options menu as "Edit me").    Edit this puzzle to create (you will see it under the Options menu as "Edit me").    Edit this puzzle to create 
the first puzzle for your new peg board.the first puzzle for your new peg board.

Copy Board:    Use this command to create a new peg board, using the currently Copy Board:    Use this command to create a new peg board, using the currently 
selected peg board as a template.selected peg board as a template.

Edit Board:    Use this command to edit an existing board.    Be careful since someEdit Board:    Use this command to edit an existing board.    Be careful since some
of the puzzles already created for that board may not be solvable after editing the of the puzzles already created for that board may not be solvable after editing the 
board.    I really don't recommend using this command, but I put it in so someone board.    I really don't recommend using this command, but I put it in so someone 
wouldn't suggest that I put into the next version (seriously, though, I do like wouldn't suggest that I put into the next version (seriously, though, I do like 
getting suggestions).getting suggestions).

Delete Board:    Use this command to delete a board you've created.    You can't Delete Board:    Use this command to delete a board you've created.    You can't 
edit or delete my boards, though (suprised?).    Be careful since I don't have and edit or delete my boards, though (suprised?).    Be careful since I don't have and 
Undo command and once you've deleted a board, it's gone forever.Undo command and once you've deleted a board, it's gone forever.

Save:    Use the Save command from the Custom menu to save the puzzle or board 
you're creating/editing (or use the "Save" smart-icon).    The boards and puzzles will be 
saved into the resource fork of the Pegged program itself, so the program must be on a 
writable volume.    When saving a board or puzzle, you get a chance to enter the name 
to be given to your creation.    This name will appear in the appropriate menu (boards in 
the board menu, and puzzles in the puzzles menu) and can be selected by users.    After
saving, you will leave edit mode.

User-created boards and puzzles will be separated in the board and puzzle menu from 
those originals included in the program (a dashed line will separate them).    This way 
you can figure out who to blame for a particular puzzle (me or somebody else).    If you 
create some interesting boards/puzzles, please send them to me.    If I'm impressed 
(and believe me, it doesn't take much to do that), I might just add your puzzle to the 
original ones included in the game.



Abort:    To leave edit mode without saving, use this command (or smart-icon).

>Topic<Smart Icons
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Just above the playing board, there is a row of smart-icons that can be used to perform 
many functions.    This saves you the time of having to get that mouse all the way up to 
the menu bar (and it can be far, far away on some larger monitors now, can't it) or 
having to memorize command-key equivalents.    Why are they called "smart-icons"?    I 
don't know.    Maybe they know something we don't.    Anyway, I think they're kind of neat
and if Microsoft products have them, they must be something worthwhile!    Below is a 
description of the smart icons in order from left to right.

Play:    This starts a new game.

Take Back Move:    Use this smart-icon to take back a move (also works while you're 
creating/editing a puzzle).

Next Puzzle:    Use this smart-icon go to the next puzzle on the same board.    If you are 
already on the last puzzle, the first puzzle will be selected.

Previous Puzzle:    Use this smart-icon go to the previous puzzle on the same board.    If 
you are on the first puzzle, the last puzzle will be selected.

Next Board:    Use this smart-icon go to the next board (the first puzzle of that board will 
be selected).    If you are already on the last board, the first board will be selected.

Previous Board:    Use this smart-icon go to the previous board (the first puzzle of that 
board will be selected).    If you are on the first board, the last board will be selected.

New Puzzle:    Use this smart-icon to create a new puzzle for the current board.    See 
Creating Puzzles for more information.

New Board:    Use this smart-icon to create a new board.    See Creating Boards for 
more information.

Save:    The save smart-icon can be used to save the puzzle or board that you're 
creating/editing.

Abort:    Use the abort smart-icon if you really screw something up and don't want to 
save it (and I know this happens a lot).


